• iCloud mail glitch

    From andekl_no@andekl_no@saaf_spam.se (=?ISO-8859-1?Q?Anders_Ekl=F6f?=) to comp.sys.mac.apps on Mon Sep 28 08:31:49 2020
    From Newsgroup: comp.sys.mac.apps

    In my iCloud mailbox, I have created a number of folders for sorting
    mail from some frequent senders.
    One of them is labelled "Apple", Usually works fine.

    Howaver, last week th Apple folder was gone from my MacBook, but is
    still present on my iMac.

    Moreover, all the 114 mails in the Apple Folder, dating from 2011 and
    onward, now appear in the "iCloud" folder under the "Drafts" tag as
    unsent, and with me as addressee.
    There is an empty "Drafts" folder under the "iCloud" tag.

    I can't move the folder containing the mails back to the iCloud tag (obviiouslly the mail are still on the iCloud server) or anywhere else
    for that matter.

    How can I fix this without scewing things up ?
    Is it as easy as executing "Rebuild" in the Mailbox menu?

    Both Macs are running Mojave 10.14.6.

    --
    I recommend Macs to my friends, and Windows machines
    to those whom I don't mind billing by the hour
    --- Synchronet 3.18a-Linux NewsLink 1.113
  • From christian180801@christian180801@ghanart.org (Christian) to comp.sys.mac.apps on Mon Sep 28 11:47:12 2020
    From Newsgroup: comp.sys.mac.apps

    Anders Eklöf <andekl_no@saaf_spam.se> wrote:

    In my iCloud mailbox, I have created a number of folders for sorting
    mail from some frequent senders.
    One of them is labelled "Apple", Usually works fine.

    Howaver, last week th Apple folder was gone from my MacBook, but is
    still present on my iMac.

    Moreover, all the 114 mails in the Apple Folder, dating from 2011 and
    onward, now appear in the "iCloud" folder under the "Drafts" tag as
    unsent, and with me as addressee.

    Are these "unsent" messages where they should be on the iMac, and the
    problem only on the MacBook?

    Then, you could delete the whole account on the MacBook and set it up
    again. It should then automatically be synchronized with the server.

    What I would _not_ do in this moment is: on the MacBook right-click on
    the account and selecht "synchronize". If the synchronization goes the
    wrong way, you have the same mess on the iMac which you have now on the MacBook.

    --- Synchronet 3.18a-Linux NewsLink 1.113
  • From Lewis@g.kreme@kreme.dont-email.me to comp.sys.mac.apps on Mon Sep 28 10:49:04 2020
    From Newsgroup: comp.sys.mac.apps

    In message <1oxfv4l.1tnl5t2150rkh7N%christian180801@ghanart.org> Christian <christian180801@ghanart.org> wrote:
    Anders Eklöf <andekl_no@saaf_spam.se> wrote:

    In my iCloud mailbox, I have created a number of folders for sorting
    mail from some frequent senders.
    One of them is labelled "Apple", Usually works fine.

    Howaver, last week th Apple folder was gone from my MacBook, but is
    still present on my iMac.

    Moreover, all the 114 mails in the Apple Folder, dating from 2011 and
    onward, now appear in the "iCloud" folder under the "Drafts" tag as
    unsent, and with me as addressee.

    Are these "unsent" messages where they should be on the iMac, and the
    problem only on the MacBook?

    Then, you could delete the whole account on the MacBook and set it up
    again. It should then automatically be synchronized with the server.

    That should work, but I would first try rebuilding the mail database. If
    the mail on iCloud.com looks correct, as I'm sure it does based on your
    other machine, and you are just having trouble with one or two
    mailboxes, choose "Rebuild" from the mailbox menu. This forces the mail
    app to redownload the mailbox from the server.

    If you are having trouble across many mailboxes, or if you have many GBs
    of mail and a slow connection, you might want to force the entire mail
    database to rebuild. This is a tedious and somewhat risky processes, and shouldn’t be undertaken lightly, so I'll not post here how to do it.

    What I would _not_ do in this moment is: on the MacBook right-click on
    the account and selecht "synchronize". If the synchronization goes the
    wrong way, you have the same mess on the iMac which you have now on the MacBook.

    I don't think so. Synchronize should only sync iCloud data down to
    the Mac. This is not the case with other accounts, necessarily, but it
    still seems to prefer the server side mail over the local storage.

    OTOH, why risk it? Rebuild will almost certainly work, and if not that, removing and readding the account will.

    --
    Tick: The judge you requested for trial -- the wombat.
    Margo: Wombat? Jesus, Tick I said combat. We wanted trial by combat.
    --- Synchronet 3.18a-Linux NewsLink 1.113
  • From andekl_no@andekl_no@saaf_spam.se (=?ISO-8859-1?Q?Anders_Ekl=F6f?=) to comp.sys.mac.apps on Wed Sep 30 10:07:49 2020
    From Newsgroup: comp.sys.mac.apps

    Thank you I will try rebuild, then.

    Yes, only the MacBook seems to have this glitch - The Apple folder is
    present and filled on iCloud.com, and the Drafts folder is empty.
    Ditto on my mobile devices./Anders

    Lewis <g.kreme@kreme.dont-email.me> wrote:

    In message <1oxfv4l.1tnl5t2150rkh7N%christian180801@ghanart.org> Christian
    <christian180801@ghanart.org> wrote:
    Anders Eklöf <andekl_no@saaf_spam.se> wrote:

    In my iCloud mailbox, I have created a number of folders for sorting
    mail from some frequent senders.
    One of them is labelled "Apple", Usually works fine.

    Howaver, last week th Apple folder was gone from my MacBook, but is
    still present on my iMac.

    Moreover, all the 114 mails in the Apple Folder, dating from 2011 and
    onward, now appear in the "iCloud" folder under the "Drafts" tag as
    unsent, and with me as addressee.

    Are these "unsent" messages where they should be on the iMac, and the problem only on the MacBook?

    Then, you could delete the whole account on the MacBook and set it up again. It should then automatically be synchronized with the server.

    That should work, but I would first try rebuilding the mail database. If
    the mail on iCloud.com looks correct, as I'm sure it does based on your
    other machine, and you are just having trouble with one or two
    mailboxes, choose "Rebuild" from the mailbox menu. This forces the mail
    app to redownload the mailbox from the server.

    If you are having trouble across many mailboxes, or if you have many GBs
    of mail and a slow connection, you might want to force the entire mail database to rebuild. This is a tedious and somewhat risky processes, and shouldn't be undertaken lightly, so I'll not post here how to do it.

    What I would _not_ do in this moment is: on the MacBook right-click on
    the account and selecht "synchronize". If the synchronization goes the wrong way, you have the same mess on the iMac which you have now on the MacBook.

    I don't think so. Synchronize should only sync iCloud data down to
    the Mac. This is not the case with other accounts, necessarily, but it
    still seems to prefer the server side mail over the local storage.

    OTOH, why risk it? Rebuild will almost certainly work, and if not that, removing and readding the account will.


    --
    I recommend Macs to my friends, and Windows machines
    to those whom I don't mind billing by the hour
    --- Synchronet 3.18a-Linux NewsLink 1.113
  • From christian180801@christian180801@ghanart.org (Christian) to comp.sys.mac.apps on Wed Sep 30 21:43:16 2020
    From Newsgroup: comp.sys.mac.apps

    Lewis <g.kreme@kreme.dont-email.me> wrote:

    In message <1oxfv4l.1tnl5t2150rkh7N%christian180801@ghanart.org> Christian <christian180801@ghanart.org> wrote:

    What I would _not_ do in this moment is: on the MacBook right-click on
    the account and selecht "synchronize". If the synchronization goes the wrong way, you have the same mess on the iMac which you have now on the MacBook.

    I don't think so. Synchronize should only sync iCloud data down to
    the Mac. This is not the case with other accounts, necessarily, but it
    still seems to prefer the server side mail over the local storage.

    Are you VERY sure about this? When a message is trashed on a computer,
    it won't be trashed on the server and therefore re-appear on the
    computer at the next connection / synchronization?

    This would be a nightmare...

    But then - I don't really care.
    --- Synchronet 3.18a-Linux NewsLink 1.113
  • From John McWilliams@jpmcw@comcast.net to comp.sys.mac.apps on Wed Sep 30 14:08:48 2020
    From Newsgroup: comp.sys.mac.apps

    On 9/30/20 PDT 1:07 AM, Anders Eklöf wrote:
    Thank you I will try rebuild, then.

    Yes, only the MacBook seems to have this glitch - The Apple folder is
    << Snipped bits out >>


    Please bottom post.
    --- Synchronet 3.18a-Linux NewsLink 1.113
  • From Lewis@g.kreme@kreme.dont-email.me to comp.sys.mac.apps on Thu Oct 1 05:07:58 2020
    From Newsgroup: comp.sys.mac.apps

    In message <1oxkc60.hic5jc1cptv5iN%christian180801@ghanart.org> Christian <christian180801@ghanart.org> wrote:
    Lewis <g.kreme@kreme.dont-email.me> wrote:

    In message <1oxfv4l.1tnl5t2150rkh7N%christian180801@ghanart.org> Christian >> <christian180801@ghanart.org> wrote:

    What I would _not_ do in this moment is: on the MacBook right-click on
    the account and selecht "synchronize". If the synchronization goes the
    wrong way, you have the same mess on the iMac which you have now on the
    MacBook.

    I don't think so. Synchronize should only sync iCloud data down to
    the Mac. This is not the case with other accounts, necessarily, but it
    still seems to prefer the server side mail over the local storage.

    Are you VERY sure about this? When a message is trashed on a computer,
    it won't be trashed on the server and therefore re-appear on the
    computer at the next connection / synchronization?

    When you delete a message on your computer via your mail application,
    what you are actually doing is sending a IMAP command to marked the
    message as deleted. that mark is synced to your computer.

    If you go into the mail storage and manually delete a mail file, then
    the mail will be resynced from your server to your computer.

    --
    When someone is impatient and says, "I haven't got all day," I always
    wonder, How can that be? How can you not have all day?
    --- Synchronet 3.18a-Linux NewsLink 1.113
  • From andekl_no@andekl_no@saaf_spam.se (=?ISO-8859-1?Q?Anders_Ekl=F6f?=) to comp.sys.mac.apps on Thu Oct 1 19:40:23 2020
    From Newsgroup: comp.sys.mac.apps

    John McWilliams <jpmcw@comcast.net> wrote:

    On 9/30/20 PDT 1:07 AM, Anders Eklöf wrote:
    Thank you I will try rebuild, then.

    Yes, only the MacBook seems to have this glitch - The Apple folder is
    << Snipped bits out >>



    Please bottom post.

    O course. Sorry

    --
    A: Because it messes up the order in which people normally read text.
    Q: Why is top-posting such a bad thing?
    A: Top-posting.
    Q: What is the most annoying thing on usenet and in e-mail?
    --- Synchronet 3.18a-Linux NewsLink 1.113
  • From andekl_no@andekl_no@saaf_spam.se (=?ISO-8859-1?Q?Anders_Ekl=F6f?=) to comp.sys.mac.apps on Sat Oct 10 19:49:36 2020
    From Newsgroup: comp.sys.mac.apps

    Lewis <g.kreme@kreme.dont-email.me> wrote:

    In message <1oxfv4l.1tnl5t2150rkh7N%christian180801@ghanart.org> Christian <christian180801@ghanart.org> wrote: > Anders Eklöf
    <andekl_no@saaf_spam.se> wrote:

    In my iCloud mailbox, I have created a number of folders for sorting
    mail from some frequent senders.
    One of them is labelled "Apple", Usually works fine.

    Howaver, last week th Apple folder was gone from my MacBook, but is
    still present on my iMac.

    Moreover, all the 114 mails in the Apple Folder, dating from 2011 and
    onward, now appear in the "iCloud" folder under the "Drafts" tag as
    unsent, and with me as addressee.

    Are these "unsent" messages where they should be on the iMac, and the problem only on the MacBook?

    Then, you could delete the whole account on the MacBook and set it up again. It should then automatically be synchronized with the server.

    That should work, but I would first try rebuilding the mail database. If
    the mail on iCloud.com looks correct, as I'm sure it does based on your
    other machine, and you are just having trouble with one or two
    mailboxes, choose "Rebuild" from the mailbox menu. This forces the mail
    app to redownload the mailbox from the server.

    If you are having trouble across many mailboxes, or if you have many GBs
    of mail and a slow connection, you might want to force the entire mail database to rebuild. This is a tedious and somewhat risky processes, and shouldn't be undertaken lightly, so I'll not post here how to do it.

    What I would _not_ do in this moment is: on the MacBook right-click on
    the account and selecht "synchronize". If the synchronization goes the wrong way, you have the same mess on the iMac which you have now on the MacBook.

    I don't think so. Synchronize should only sync iCloud data down to
    the Mac. This is not the case with other accounts, necessarily, but it
    still seems to prefer the server side mail over the local storage.

    OTOH, why risk it? Rebuild will almost certainly work, and if not that, removing and readding the account will.

    The solution turned out to be even simpler- but not easy to find:
    For some reason "Apple" had been selected as the drafts folder in the
    account settings. Probably by a slip on the touchpad.

    OTOH - why is that even possible? There is a folder named "Drafts".

    --
    I recommend Macs to my friends, and Windows machines
    to those whom I don't mind billing by the hour
    --- Synchronet 3.18a-Linux NewsLink 1.113
  • From Lewis@g.kreme@kreme.dont-email.me to comp.sys.mac.apps on Sat Oct 10 19:15:29 2020
    From Newsgroup: comp.sys.mac.apps

    In message <1oy2pgv.9x5ge81bp6d61N%andekl_no@saaf_spam.se> Anders Eklöf <andekl_no@saaf_spam.se> wrote:
    Lewis <g.kreme@kreme.dont-email.me> wrote:

    In message <1oxfv4l.1tnl5t2150rkh7N%christian180801@ghanart.org> Christian >> <christian180801@ghanart.org> wrote: > Anders Eklöf
    <andekl_no@saaf_spam.se> wrote:

    In my iCloud mailbox, I have created a number of folders for sorting
    mail from some frequent senders.
    One of them is labelled "Apple", Usually works fine.

    Howaver, last week th Apple folder was gone from my MacBook, but is
    still present on my iMac.

    Moreover, all the 114 mails in the Apple Folder, dating from 2011 and
    onward, now appear in the "iCloud" folder under the "Drafts" tag as
    unsent, and with me as addressee.

    Are these "unsent" messages where they should be on the iMac, and the
    problem only on the MacBook?

    Then, you could delete the whole account on the MacBook and set it up
    again. It should then automatically be synchronized with the server.

    That should work, but I would first try rebuilding the mail database. If
    the mail on iCloud.com looks correct, as I'm sure it does based on your
    other machine, and you are just having trouble with one or two
    mailboxes, choose "Rebuild" from the mailbox menu. This forces the mail
    app to redownload the mailbox from the server.

    If you are having trouble across many mailboxes, or if you have many GBs
    of mail and a slow connection, you might want to force the entire mail
    database to rebuild. This is a tedious and somewhat risky processes, and
    shouldn't be undertaken lightly, so I'll not post here how to do it.

    What I would _not_ do in this moment is: on the MacBook right-click on
    the account and selecht "synchronize". If the synchronization goes the
    wrong way, you have the same mess on the iMac which you have now on the
    MacBook.

    I don't think so. Synchronize should only sync iCloud data down to
    the Mac. This is not the case with other accounts, necessarily, but it
    still seems to prefer the server side mail over the local storage.

    OTOH, why risk it? Rebuild will almost certainly work, and if not that,
    removing and readding the account will.

    The solution turned out to be even simpler- but not easy to find:
    For some reason "Apple" had been selected as the drafts folder in the
    account settings. Probably by a slip on the touchpad.

    OTOH - why is that even possible? There is a folder named "Drafts".

    You can set any folder you want as the Drafts, Trash, and Junk folders.


    --
    Demons have existed on the Discworld for at least as long as the
    gods, who in many ways they closely resemble. The difference is
    basically the same as between terrorists and freedom fighters.
    --- Synchronet 3.18a-Linux NewsLink 1.113